HDU 1002 A + B Problem II(大整数相加)[通俗易懂]

HDU 1002 A + B Problem II(大整数相加)

大家好,又见面了,我是全栈君。

A + B Problem II

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u


Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

 

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 

 

Sample Input

      
      
2 1 2 112233445566778899 998877665544332211

 

Sample Output

      
      
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 


题目大意:

大整数相加。

解题思路:

先把短的补齐。从最后一位開始计算。不进为就直接放进容器,进为把取余的放进容器,然后前一位加一。


代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<vector>

using namespace std;

int t;
string str1,str2;
vector <char> v;

void solve(){
    string temp;
    int a,l2;
    if(str1.length()<str2.length()){
        temp=str1;str1=str2;str2=temp;
        l2=str2.length();
    }
    for(int i=0;i<str1.length()-l2;i++){
        str2.insert(0,1,'0');
    }
    for(int i=0;i<str1.length();i++){
        a=str1[str1.length()-i-1]+str2[str2.length()-i-1]-2*'0';
        if(a>=10){
            v.push_back(a%10+'0');
            if(str1.length()-i-1==0){
                v.push_back('1');break;
            }
            str1[str1.length()-i-2]=(char)(str1[str1.length()-i-2]+1);
        }
        else v.push_back((char)(a+'0'));
    }
     vector<char>::iterator it=v.end();
     it--;
     while(it!=v.begin()){
        if(*it=='0')
            v.erase(it);
        else break;
        it--;
     }
    for(int i=v.size()-1;i>=0;i--){
       cout<<v[i];
    }
    cout<<endl;
}

int main(){
    int casen=0;
    scanf("%d",&t);
    while(t-->0){
        cin>>str1>>str2;
        printf("Case %d:\n%s + %s = ",++casen,str1.c_str(),str2.c_str());
        v.clear();
        solve();
        if(t!=0)
            cout<<endl;
    }
    return 0;
}

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员-用户IM,转载请注明出处:https://javaforall.cn/115967.html原文链接:https://javaforall.cn

【正版授权,激活自己账号】: Jetbrains全家桶Ide使用,1年售后保障,每天仅需1毛

【官方授权 正版激活】: 官方授权 正版激活 支持Jetbrains家族下所有IDE 使用个人JB账号...

(0)


相关推荐

发表回复

您的电子邮箱地址不会被公开。

关注全栈程序员社区公众号